Main website throwing occasional proxy errors
Incident Report for Cloud CMS
Resolved
An external service for page analytics experienced service issues, slowing down our site. We've mitigated all dependencies. Site operation has returned to normal.
Posted Jan 20, 2016 - 22:09 EST
Investigating
Still analyzing details; www.cloudcms.com is encountering sporadic latency problems
Posted Jan 20, 2016 - 20:51 EST